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1.Introduction

1.1 Overview

Thank you for purchasing our managed switch series, whose all software function can be managed,
configured and monitored via embedded Web-based (HTML) interface. By a standard browser, you can
manage switch at any remote site in the network. Browser as a universal access tool, uses the HTTP protocol

to communicate with switch directly.

1.2 Web Management Login

Open installed web browser on your PC, input the switch’s IP address like http:/xxx.xxx.xxx.xxx, then
open that URL to login web management.

% Note: IP address of switch is 192.168.2.1 by default. So please input http:/192.168.2.1 in browser.

When the login window appears, please enter the default username "admin" with password "admin".
Then click OK to login.

Windows Security A — @h

The server 182.168.2.1 is asking for your user name and password. The
server reports that it is from 24GF-4G.

Warning: Your user name and password will be sent using basic
authentication on a connection that isn't secure.

'J:-er name |

lPas:—wcrd |

"] Remember my credentials

[ OK ] [ Cancel

Figure1-1 Login Window

Default Username: admin
Default Password: admin


http://xxx.xxx.xxx.xxx/
http://192.168.2.1/

1.3 Web-based User Interface

After entering the username and password, the main screen appears as following Figure1-2.

»Information & Status
»Network Admin
»Port Configure Description Speed Adv Duplex Adv speed Flow Control Maximu_m E)'(c_ess
»PoE Configured Fdx Hdx 10M 100M Enable CurrRx Curr Tx Frame Size Collision
»Advanced Configure =
» Security Configure
»QoS$ Configure
»Diagnostics
»Maintenance

1Gfdx Auto Disci

v
Down Auto v v Disci

v

v

Down Auto Disci

REE®
S U YR G CY

Down Auto Disci

TR RE®
TR E®

Down Auto
Down Auto v v

XX XXXX
XXXXXX

O OB w N o

Save || Reset

Figure1-2 Web management Main Page

interface This Main Page interface includes mainly 3 parts. Here is description:

Part Description

Company LOGO; Panel display; Port indicators, including PoE and Link working
Part 1 status; Language selection button; Help document
Part 2 The Main Menu, lets you access all the commands and statistics
Part 3 Main Screen, showing configuration details

The Web agent displays an image of the Managed Switch’s ports. Different colors mean different states,
they are illustrated as follows:

: 100Mbps linked; =55: 1000Mbps linked; B Nolink

1.4 Main Menu

Using the onboard Web agent, you can define system parameters, manage and control the Managed
Switch, and all its ports, or monitor network conditions. Via the Web-Management, the administrator
can set up the Managed Switch by selecting the functions those listed in the Main Menu. Following is
short description:

Information & Status - Users can check switch information and working status under this
menu.

Network Admin - Users can check and configure related features of network under this menu.
Port Configure - Users can check and configure specification of ports under this menu.

PoOE - Users can check and configure related features of Power-over-Ethernet (PoE) under

this menu.

Advanced Configure - Users can check and configure L2 advanced features under thismenu.
Security Configure - Users can check and configure security features of the switch under this
menu.




2. Network Management

2.11P Configuration

& Note: IP address of switch is 192.168.2.1 by default, and the default subnet mask is 255.255.255.0(24)

Click "Network Admin" > "IP", screen will shows as:

» Information & Status
wNetwork Admin
= [P Config
= |P Status
»DHCPServer

IP Configuration

Mode Host v
DLRRTLTIAN | No DNS server
DL RERTLTRE | No DNS server

4|4 « «

=NTP

S DURRTLT R | No DNS server

»SNMP DL RRTHZUl | No DNS server

= SysLog DNS Proxy [
»Port Confi

RS IP Interfaces

»PoE
» Advanced Configure Delete VLAN DHCPv4 [ 2477 IPv6
» Security Configure Enable Fallback Current Lease Address Mask Length Address Mask Length
» QoS Configure 1 0 192.168.2.1 24

» Diagnostics
»Maintenance | Add Interface |

IP Routes
Delete Network Mask Length Gateway Next Hop VLAN

| Add Route

| Save || Reset

Figure 2-1 IP Configuration Screen

Following is description detail about IP configuration:

Name Description

Port Name Display system’s port name

VLAN VLAN for for access and management of switch

- If enable, it means that VLAN port start IPv4 DHCP client, to dynamically get

IPv4 addresses of the switch. Otherwise, it will use switch’s static IP
configuration.

IPv4 DHCP - Fallback (Seconds), means the waiting time for switch to get dynamic IP
address via DHCP. The value of "0" here means never over the time.
- Current Lease, means the IP address get from DHCP
IPva - Address: static IPv4 address entered by user.

- Mask Length: static IPv4 subnet mask entered by user.

Click "Add Interface" to create a new management for VLAN and IP address. Click ""Save" to save settings.



Fo.N

\ Note: The switch only created VLAN1 by default. If user needs to use other VLAN for
switch management, please first add VLAN in the VLAN module, and add the relevant port to
the VLAN.



2.2 NTP Configuration

NTP is an acronym for Network Time Protocol, a network protocol for synchronizing the clocks of
computer systems. You can specify NTP Servers and set GMT Time zone. The NTP Configuration screens
will appear after you click "Network Admin" > "NTP".

pInformation & Status
w Network Admin

= |P Config

= [P Status

» DHCPServer

NTP Configuration

Mode Disabled v
Server 1

Server 2
=« NTP

= Timezone
»SNMP
= SyslLog
» Port Configure
»PoE | Save || Reset

Server 3

Server 4
Server 5

Figure 2-2 NTP Setting Screen

Configuration object and description is:

Object Description

Click drop-down menu to select "Enabled" or "Disabled" SNTP.

Mode Enabled: Enable SNTP mode operation. When enabling SNTP mode operation,
the agent forwards and transfers SNTP messages between the clients and the
server when they are not on the same subnet domain.

Disabled: Disable SNTP mode operation.

NTP Sever

After input NTP server IP address, NTP information will be get from that server.

After configuration was set, please click "Save" to save the setting.

2.3 SNMP Configuration

Simple Network Management Protocol (SNMP) is an application layer protocol that facilitates the
exchange of management information between network devices. It is part of the Transmission Control
Protocol/Internet Protocol (TCP/IP) protocol suite. SNMP enables network administrators to manage
network performance, find and solve network problems, and plan for network growth.

This switch support SNMPv1, v2c. Different versions of SNMP provides different security level for
management stations and network devices.

In SNMP’s v1 and v2¢, it uses the "Community String" for user authentication. That string is similar to
password function. SNMP application of remote user and SNMP of the Switch must use the same
community string. SNMP packets of any unauthorized sites will be ignored (discarded).

"Community String" by default for switch’s SNMPv1 and v2c access management is:

1. public - allow authentication management station to read MIB objects.

2. private - allow authentication management station to read, write and edit MIB objects.



Trap

Used by the agent to asynchronously inform the NMS of some event. These events may be very serious,
such as reboot (someone accidentally turned off switch), or just general information, such as port status
change. In these cases, switch create trap information and send then to receiver or network admin.
Typical trap includes authentication failure, networking changes and cold/hot start trap.

A MIB is a collection of managed objects residing in a virtual information store. Collections of related
managed objects are defined in specific MIB modules. Switch uses standard MIB-Il information
management module.

So, MIB object value can be read by any SNMP web-managed software.

2.3.1SNMP System Configuration

You can enable or disable the SNMP System Configuration. Its screen will appear after you click
“Network Admin" > "SNMP" > "System"

»Information & Status
w Network Admin
= |P Config
= |P Status
pDHCPServer

SNMP System Configuration

Mode Enabled Y
Version ' SNMP v2c v
Read Community RJiiy

= NTP
= [Imezone
»SNMP

= System
= Trap | Save || Reset |

Write Community private
Engine ID 800007e5017f000001

= Communities

Figure 2-3 SNMP System Setting Screen

Configuration object and description is:

Object Description

Mode Enabled or Disable SNMP function
Version Click drop-down menu to select SNMP v2c or SNMP v1 version
Read Public: allow authentication management station to read MIB objects
Community
Write Private: allow authentication management station to read and write MIB
Community objects.

2.3.2SNMP Trap Configuration

User can enable or disable SNMP Trap function and set configuration. Click "Network Admin" >
"SNMP" > "Trap", then this screen will show as:

pInformation & Status
w Network Admin

= IP Config Global Settings
= |P Status

» DHCPServer 1\6LES | Disabled v

=« NTP

Trap Configuration

Trap Destination Configurations

= limezone

v SNMP Delete Name Enable Version Destination Address Destination Port

= System
= Trap | Add New Entry |
= Communities -

L Save | Reset |




2.4 System Log Configuration

User can configure switch’s system log, via following screen after click "Network Admin" > "Syslog"

) Information & Status
wNetwork Admin

= [P Config

= |P Status

p DHCPServer

System Log Configuration

Server Mode M[_)i_sra_bled_ B Al
Server Address »_1_92_.168_.2‘. 1 0.0
Syslog Level Informational v

=« NTP
= {iMmezone
pSNMP

= SysLog

| Save || Reset |

Figure 2-4 System Log Configuration

Screen Configuration object and description is:

Object Description

Enabled or Disable SNMP System Log function. If "Enable"is selected, switch will

Server Mode send System Log to defined server.

Server Address |Defined server IP address

To define level of System Log,
including: Info: Information, warnings
and errors. Warning: warnings and
errors.

Error: errors.

Syslog Level

3. Port Configure

3.1Port Configuration

This page is for configuring port specifications of switch. After click "Port Configure" > "Ports", this
screen will appear as:

»information & Status

»Network Admin Port Configuration | Refresh |
wPort Configure Description Speed Adyv Duplex Adv speed Flow Control Maximum Excessive Frame
«Ports P Configured Fdx Hdx 10M 100M 1G Enable CurrRx Curr Tx Frame Size Collision Mode Length Check
»Aggregation A <> v 2 < v v 2 9600 <>
= Mirroring 1 1Gfdx Auto v v v 4 ] < e 9600 Discard v
= Thermal Protection .
 Green Ethemet 2 ® oo Auto @ @ ¥ @ @ 5 x 9600 Discard v
»DDM 3 @ Dovn Auto v v v v v X S 9600 Discard ¥
»PoE 4 ® Down Auto “ © @ ¢ W X x 9600 Discard v
»Advanced Configure 5 ® Dovn Auto v v X X 9600
» Security Configure 6 ® Down Auto v v v v v v X X 9600

»QoS Configure
»Diagnostics | Save || Reset

Figure 3-1 Port Configure Screen




Configuration object and description is:

Object Description

Link Red color means Link Down, green color means Link Up

Select the port speed and full / half duplex

mode. "Disabled" means that port is disabled.

"Auto" meaning in full-duplex (FDX) or half-duplex mode (HDX) (1000mbps
always in full-duplex mode) auto negotiate among 10,100,1000Mbps devices.
Speed "Auto" setting allows the port to automatically determine the fastest settings
for the device connected, and to apply these settings.

"1000-X_AMS" means that port is Ethernet/Optical combo port, and optical
port is prioritized.

Other options are 10M HDX, 10M FDX, 100M HDX, 100M FDX, 1000M FDX, 1000-
X.

It is a flow control mechanism for a variety of port configurations. Full-duplex ports
use 802.3x flow control, half-duplex ports use backpressure flow control. It is
Flow <abl faul
Control disabled by default.

Check to enable flow control.

Maximum It is used to set the maximum frame size for Ethernet. The default setting is 9600,
Frame Size which is to support Jumbo frames.

Click "Save" to store and active settings.

3.2Link Aggregation

Users can set up multiple links among multiple switches. Link Aggregation, is a method that tie some
physical ports together as one logic port, to enlarge bandwidth. This switch supports up to 13 groups
Link Aggregation, 2 to 8 port as one group.

& Note: If any port in the link aggregation group is disconnected, data packet that sent to

disconnected port will share load with other connected port in this aggregation group.

3.2.1Static Aggregation

In this page, user can configure static aggregation of switch’s ports. After click the menu "Port Configure" >
"Aggregation" > "Static", followed window will appear for making static aggregation settings.



Information & Status & . i
> ¢ Aggregation Mode Configuration
» Network Admin

w Port Configure

Hash Code Contributors
= Ports Source MAC Address v
wAggregation Destination MAC Address ¢
= Static IP Address L4
= LACP TCP/UDP Port Number L4

= Mirroring ! ; 5
= Thermal Protection Aggregation Group Configuration

Port Members

= Green Ethemnet
»DDM

GroupID 1 2 3 4 5 6
»PoE Normal ® ® @ ® ® @®
p Advanced Configure 1
» Security Configure 2

» QoS Configure 3

p Diagnostics

» Maintenance ;_§§Y9_; | Reset |

Figure 3-2 Port Static Aggregation Configuration

Screen Configuration object and description is:

Object Description

Aggregation
Mode

Configuration | This parameter is flow hash algorithm among LAG (Link Aggregated Group) ports.

Group ID Static aggregation group ID

This switch supports up to 13 groups Link Aggregation, 2 to 8 port as one group.
Port Members

Click "Save" to store and active settings.

«
Note: It allows a maximum of 8 ports to be aggregated as 1 static trunk group at the same time.



3.2.2LACP Aggregation

Link Aggregation Control Protocol (LACP) provides a standardized means for exchanging information
between Partner Systems that require high-speed redundant links. Link aggregation lets you group up
to eight consecutive ports into a single dedicated connection. This feature can expand bandwidth to a
device on the network. LACP operation requires full-duplex mode. For more detailed information, refer
to the IEEE 802.3ad standard.

Users can create dynamic aggregation group for switches. After click "Port Configure" > "Aggregation”
> "LACP", users can set LACP configuration in followed screen.

»Information & Status

LACP Port Configuration

» Network Admin
v Port Configure Port LACP Enabled Key Role Timeout Prio
« Ports * <> v <> v < v 32768
'Agg'seé:“m 1 Auto v Active v| |[Fast v 32768
= C
« LACP 2 Auto v Active v Fast v 32768
= Mirroring 3 Auto v Active v Fast v 32768
= Thermal Protection 4 Auto v Active v| |[Fast v 32768
= Green Ethernet 5
»DDM 5 Auto v Active v Fast v 32768
» PoE 6 Auto v Active v Fast v 32768

p Advanced Configure
» Security Configure

L Save i Resetr

Figure 3-3 LACP Configuration

Screen Configuration object and description is:

Object Descriptio

n

LACP Enable or disable LACP function of that port.

The Key value incurred by the port, range 1-65535. The Auto setting will set the
Key key as appropriate by the physical link speed, 10Mb = 1, 100Mb = 2, 1Gb = 3.
Using the Specific setting, a user-defined value can be entered. Ports with the
same Key value can participate in the same aggregation group, while ports with
different keys cannot.

The Role shows the LACP activity status. The Active will transmit LACP packets
each second, while Passive will wait for a LACP packet from a partner (speak if
spoken to).

Role

The Timeout controls the period between BPDU transmissions. Fast will
Timeout transmit LACP packets each second, while Slow will wait for 30 seconds before
sending a LACP packet.

The Prio controls the priority of the port. If the LACP partner wants to form a
larger group than is supported by this device then this parameter will control
which ports will be active and which ports will be in a backup role. Lower
number means greater priority.

Prio

Click "Save" to store and active settings.



3.3 Port Mirroring

Configure port Mirroring on this page. This function provides monitoring of network traffic that
forwards a copy of each incoming or outgoing packet from one port of a network switch to another port
where the packet can be studied. It enables the manager to keep close track of switch performance and

alter it if necessary.

To configure Mirror settings, please click "Port Configure" > "Mirroring" . Then followed screen will appear

as:

p Information & Status
» Network Admin

v Port Configure Port to mirror to [f] v

Mirror Configuration

= Poris

» Aggregation Mirror Port Configuration

= Mirroring

= Thermal Protection — <> -

= Green Ethernet -

»DDM 1 | Disabled v
»PoE 3 glsablled :
» Advanced Configure LRIl

5 4 |Txonly v
» Security Configure —
5 |Disabled v
» QoS Configure :
s ibncetice 6 rDlsabled v
e CPU | Disabled v

»Maintenance

| Save || Reset |

Figure 3-4 Mirror Configuration

Screen Configuration object and description is:

Object Description

Frames from ports that have either source (rx) or destination (tx) mirroring

Porttrglrror enabled are mirrored on this port. Disabled disables mirroring.
Select source port mirror mode.
Rx only Frames received on this port are mirrored on the mirror port.
Frames transmitted are not mirrored.
Tx only Frames transmitted on this port are mirrored on the mirror port.
Mode Frames received are not mirrored.

Disabled Neither frames transmitted nor frames received are mirrored.
Enabled Frames received and frames transmitted are mirrored on the mirror
port. Note: For a given port, a frame is only transmitted once. It is therefore
not possible to mirror mirror port Tx frames. Because of this, mode for the
selected mirror port is limited to Disabled or Rx only.

Click "Save" to store and active settings.

Y
N
b
b
b

Note: You can not set fast speed port(s) mirror to a low speed port. For example, there is
problem if you try to mirror 100Mbps port(s) to a 10 Mbps port. So destination port should has equal or
higher speed comparing to source port. Besides, source port and destination port should not be same

one.



3.4 Thermal Protection Configuration

Thermal protection is for detecting and protecting working switch. When switch detected port
temperature is higher that defined temperature, system will disable the port, to protect switch itself.

After click "Port Configure" > "Thermal Protection”, followed screen will appear as:

pinformation & Status

Thermal Protection Configuration

» Network Admin
v Port Configure Temperature settings for groups
= Ports
»Aggregation Temperature
= Mirroring 0 255 | C
= Thermal Protection 1 1255 26
= Green Ethemet o
»DDM 2 |255 c,C
) PoE 3 [255 C
» Advanced Configure Port groups
» Security Configure
» QoS Configure
» Diagnostics <> bl
» Maintenance 1 |Disabled ¥
1 v
3 (3 v |
4 | Disabled v
5 | Disabled v |
6 | Disabled ¥
' Save | Reset |

f |

Figure 3-5 Thermal Protection Configuration Screen

Configuration object and description is:

Object Description

Temperature settings | This switch support 4 Thermal Protection priority groups, and each of
for priority groups them can have a defined temperature for protection.

Port priorities Define which priority group that port belong to.

Click "Save" to store and active settings.

«
Note: By default, all ports of switch are belong to Priority Group 0, with protected
temperature 225 degree C.



4. PoE Configuration

Power-over-Ethernet (PoE), means Ethernet network power supply via 100BASE-TX, 1000BASE-T. Its
maximum power distance is 100 meters. By PoE power system, based on Ethernet wiring network of UTP
Catb or higher Cable, it can give power to IP camera, VolP phone, wireless AP, as well as transmit data. So
there is no need to concern about the power wire building, reducing the cost of networking building.

PoE power supply system has unified standard, IEEE 802.3af and 802.3at. So devices from different
manufacturers have no problem in general usage, as long as they are complied with these standards.

PD, it is defined as powered device in the PoE Power Supply System , primarily including IP camera, wireless
AP, network VolP phone, and other IP-based terminal equipment.

The whole process of PoE:

1. Detection: At beginning, PSE device output a very small voltage, to detect and judge if its linked PD is
IEEEB02.3af / IEEE802.3at compliant device. Only if detected that PD is a standard compliant device, then it
will go to next step.

2. PD Classification: After detected PDs, PSE will classify them and recognize what is the power that PD
required.

3. Power up: When above 2 steps finished, PSE start feeding required power for PD, with 44~57VDC output
voltage.

4. Power supply: PSE provides stable 44~57V DC to PDs, and auto feeding power as requirement of PDs.
Maximum power of single PoE port for IEEE 802.3af devices: 15.4W; Maximum power of single PoE port for
IEEE 802.3at devices: 25.5W.

5. Disconnection: If PD is disconnected or user disable PoE from management software, PSE will quickly(300-
400ms) stop powering PD.

In any moment of PSE powering PD process, PSE will stop working and then restart from step1 if abnormal
situation happens, such as PD Short circuit, power consumption is higher than feeding power, and so on.

4.1PoE Setting

After click "PoE"> "PoE Setting", user can make PoE settings in followed screen:

»information & Status
» Network Admin
» Port Configure
wPoE

= PoE Setting

= PoE Scheduling

= PoE Status PoE Power Supply Configuration
»Advanced Configure

» Security Configure Primary Power Supply [W]
» QoS Configure 120

Power Over Ethernet Configuration

Reserved Power determined by RONNT) Manual
Power Management Mode ® Actual Consumption '’ Reserved Power
Capacitor Detection *® Disabled Enabled

» Diagnostics
»Maintenance

PoE Port Configuration

PoE Mode Priority PD Alive Check Maximum Power [W] Description
<> v <> v <> v 154
1 [PoE+ v| [Low v OFF v 154
2 PoE+ v| |High v ON v| | 15.4
3 |PoE+ v| |Critical v ON v 15.4
4 [PoE+ v| [Low OFF v| | 154

‘7 Save || Reset |

Figure 4-1 PoE Setting Screen



Configuration object and description is:

Object Description

This switch supports 2 modes for reserved power determination.

Auto: Switch automatically assigned maximum power of switch port
according to detected PD class. About PD Class, please refer to the
802.3af / 802.3at definition.

Manual: Maximum reserved power of the port is customize by the user.

Reserved Power
determined by

This switch supports 2 modes for Power Management.

1. Actual Consumption: In this mode, when the actual power consumption
of all the ports exceeds the switch’s power budget, the lowest priority port
will be shut down. If all ports have the same priority, then the maximum
port number would be shut down.

2. Reserved Power: In this mode, when the reserved power consumption
of all the ports exceeds the switch’s power budget, the port that connect
to new PD will not be enabled.

Power Management
Mode

Users can set the maximum primary power of the whole switch.

Primary Power Supply Default setting is 370W.

[wW1]
PoE Mode ThIS. SWI.’[Ch support 802.3af (PoE) and 802.3at(PoE+) mode. Default
setting is 802.3at.
Priority Define the priority of the PoE port. Priority from low to high is Low, High,

Critical.

It is for define port’s maximum Power when user set Manual as

Maximum P r (W L
aximum Power (W) reserved power determination mode.

Click "Save" to store and active settings.

4.2 PoE Status

In this page, user can check and look PoE status of all ports, after click "PoE"> "PoE Status".

Information & Statu:
::e::rk:nam " Power Over Ethernet Status Autoreiesh Refresh

»Port Configure Local Port Description PD class Power Requested Power Allocated Power Used Current Used Priority
~+PoE 1 0 0[W] 0W] 0 W] 0 [mA] Low 0 PoE turned OFF|

+ PoE Setting 2 0 0w) ow] oW 0 [mA] Low 0 PoE turned OFF
+ PoE Schedling 3 0 0w 0w] 0w 0 [mA] Low 0 POE turned OFF
+ PoE Status 4 0 0[w] (] oW 0 [mA] Low 0 POE turned OFF
S Beeey Coungars Total 0w 0w] oW 0 [mA]

Figure 4-2 PoE Status Screen



5. Advanced Configure

5.1 VLAN

VLAN (Virtual Local Area Network) logically divide one LAN (Local Area Network) into a plurality of subsets,
and each subset will form their own broadcast area network. In short, VLAN is a communication technology
that logically divide one physical LAN into multiple broadcast area network (multiple VLAN). Hosts within a
VLAN can communicate directly. But VLAN groups can not directly communicate with each other. So it will
limit the broadcast packets within a VLAN. Since it can not directly access between VLAN groups, thus it
improves network security.

Click "Advanced Configure"> "VLANs" to see 802.1Q VLAN configuration screen as following:

»Information & Status .
e Global VLAN Configuration

»Port Configure Allowed Access VLANs 1
»PoE Ethertype for Custom S-ports B0
wAdvanced Configure

= MAC Table Port VLAN Configuration

= VLANS e
X Port Ingress Forbidden
AL ERIEL VIAN  PortT¥Pe  Eiering i VLANs

Port Mode

»GVRP

= <> v = v
»Port Isolation
« Loop Protection 1 [Access ¥
»Spanning Tree 2 | Access v
»IPMC Profile 3 |Access v
=MEP 4 | Access ¥
RERES 5 |Access v
HIOMESonng 6 |Access ¥
»IPV6 MLD Snooping
TR Save || Reset

» Security Configure

Figure 5-1 802.1Q VLAN Configuration Screen

Configuration object and description is:

Object Description

Allowed Here displays created VLAN ID. It is 1 by default. If you want to create new VLAN,
VLANS just need to add VLAN ID here.

Ethertype for |This field specifies the ethertype/TPID (specified in hexadecimal) used for
Custom S-ports | Custom S- ports. The setting is in force for all ports whose Port Type is set to S-
Custom-Port.

The port mode (default is Access) determines the fundamental behavior of the
port in guestion. A port can be in one of three modes as described below.
Whenever a particular mode is selected, the remaining fields in that row will be
either grayed out or made changeable depending on the mode in question.
Grayed out fields show the value that the port will get when the mode is applied.

Mode Access:
Access ports are normally used to connect to end stations. Access ports have
the following characteristics:

e Member of exactly one VLAN, the Port VLAN (a.k.a. Access VLAN), which
by default is 1
e Accepts untagged and C-tagged frames
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e Discards all frames that are not classified to the Access VLAN
e On egress all frames classified to the Access VLAN are transmitted
untagged. Other (dynamically added VLANSs) are transmitted tagged

Trunk:
Trunk ports can carry traffic on multiple VLANs simultaneously, and are normally
used to connect to other switches. Trunk ports have the following characteristics:

e By default, a trunk port is member of all VLANs (1-4094)

e The VLANSs that a trunk port is member of may be limited by the use of
Allowed VLANs

e Frames classified to a VLAN that the port is not a member of are discarded

e By default, all frames but frames classified to the Port VLAN (a.k.a. Native
VLAN) get tagged on egress. Frames classified to the Port VLAN do not get
C- tagged on egress

e Egress tagging can be changed to tag all frames, in which case only
tagged frames are accepted on ingress

Hybrid:

Hybrid ports resemble trunk ports in many ways, but adds additional port
configuration features. In addition to the characteristics described for trunk
ports, hybrid ports have these abilities:

e Can be configured to be VLAN tag unaware, C-tag aware, S-tag aware, or
S- custom-tag aware

e Ingress filtering can be controlled

e Ingress acceptance of frames and configuration of egress tagging can
be configured independently

Determines the port's VLAN ID (a.k.a. PVID). Allowed VLANSs are in the range 1
through 4094, default being 1.

On ingress, frames get classified to the Port VLAN if the port is configured as
VLAN unaware, the frame is untagged, or VLAN awareness is enabled on the

Port VLAN port, but the frame is priority tagged (VLAN ID = 0).
On egress, frames classified to the Port VLAN do not get tagged if Egress Tagging
configuration is set to untag Port VLAN.
The Port VLAN is called an "Access VLAN" for ports in Access mode and Native
VLAN for ports in Trunk or Hybrid mode.
Ports in hybrid mode allow for changing the port type, that is, whether a frame's
VLAN tag is used to classify the frame on ingress to a particular VLAN, and if so,
which TPID it reacts on. Likewise, on egress, the Port Type determines the TPID of the
tag, if a tag is required.
Unaware:
On ingress, all frames, whether carrying a VLAN tag or not, get classified to the
Port VLAN, and possible tags are not removed on egress.

Port Type C-Port:

On ingress, frames with a VLAN tag with TPID = 0x8100 get classified to the VLAN ID
embedded in the tag. If a frame is untagged or priority tagged, the frame gets
classified to the Port VLAN. If frames must be tagged on egress, they will be tagged
with a C-tag.

S-Port:

On ingress, frames with a VLAN tag with TPID = 0x8100 or 0x88A8 get classified to
the VLAN ID embedded in the tag. If a frame is untagged or priority tagged, the
frame gets classified to the Port VLAN. If frames must be tagged on egress, they will
be tagged with an S-tag.
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S-Custom-Port:

On ingress, frames with a VLAN tag with a TPID = 0x8100 or equal to the Ethertype
configured for Custom-S ports get classified to the VLAN ID embedded in the tag. If
a frame is untagged or priority tagged, the frame gets classified to the Port VLAN. If
frames must be tagged on egress, they will be tagged with the custom S-tag.

Ingress Filter

Hybrid ports allow for changing ingress filtering. Access and Trunk ports always
have ingress filtering enabled.

If ingress filtering is enabled (checkbox is checked), frames classified to a VLAN that
the port is not a member of get discarded.

If ingress filtering is disabled, frames classified to a VLAN that the port is not a
member of are accepted and forwarded to the switch engine. However, the port will
never transmit frames classified to VLANs that it is not a member of.,

Hybrid ports allow for changing the type of frames that are accepted on ingress.

Tagged and Untagged
Both tagged and untagged frames are accepted.

Ingress
Acceptance Tagged Only
Only tagged frames are accepted on ingress. Untagged frames are discarded.
Untagged Only
Only untagged frames are accepted on ingress. Tagged frames are discarded.
Ports in Trunk and Hybrid mode may control the tagging of frames on egress.
Untag Port VLAN
Frames classified to the Port VLAN are transmitted untagged. Other frames
are transmitted with the relevant tag.
Egress
Tagging Tag All
All frames, whether classified to the Port VLAN or not, are transmitted with a tag.
Untag All
All frames, whether classified to the Port VLAN or not, are transmitted without
a tag. This option is only available for ports in Hybrid mode.
Ports in Trunk and Hybrid mode may control which VLANSs they are allowed to
become members of. Access ports can only be member of one VLAN, the Access
Allowed VLAN.' - . . .
VLANS The field's syntax is |denfuca| to th_e syntax used in the Enabled VLANs fl_eld. By
default, a Trunk or Hybrid port will become member of all VLANs, and is therefore
set to 1-4094.
The field may be left empty, which means that the port will not become member
of any VLANs.
A port may be configured to never be member of one or more VLANs. This is
particularly useful when dynamic VLAN protocols like MVRP and GVRP must be
Forbidden prever_\tegl from dynamically adding ports to VLANS. . .
VLANS The trick is to mark such VLANSs as forbidden on the port in question. The

syntax is identical to the syntax used in the Enabled VLANs field.
By default, the field is left blank, which means that the port may become a
member of all possible VLANS.

Click "Save" to store and active settings.
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5.2 Port Isolation

Port isolation is for limiting data between ports. It is similar to VLAN, but more stricter.

5.2.1Port Group

This switch support port groups. Members of port group can forward date.

% Note: port can belong to to multiple port groups. Data can be forwarded among any port that
belong to one port group.

After Click "Advanced Configure" > "Port Isolation" > "Port Group", then followed screen will appear
for making port group configuration.

»Information & Status
» Network Admin

» Port Configure

» POoE

Port Group Membership Configuration
Port Members

Delete PortGrouplD 1 2 3 4 5 6

wAdvanced Configure 1 & ¢ « ¢ |« [«
= MAC Table
« VLANS | Add New Port Group |
pVoice VLAN
»GVRP Save || Reset |

wPort Isolation

= Port Group

Figure 5-2 Port Group Configuration

Screen Configuration object and description is:

Description

Port Members Check the corresponding box to set them as one port

Click "Add New Port Group" to create a new port group, "Delete” to remove corresponding port
group, and "Save" to store and active settings.

5.2.2Port Isolation

After Click "Advanced Configure" > "Port Isolation" > "Port Isolation", then followed screen will appear for
making port isolation configuration.



»Information & Status
» Network Admin
» Port Configure
» POE
wAdvanced Configure
= MAC Table

Port Isolation Configuration

Port Number

1 23 &% 5 &

< VLANS | Save || Reset |
» Voice VLAN
»GVRP
w Port Isolation
= Port Group
= Port Isolation

Figure 5-3 Port Isolation Configuration

Screen Configuration object and description is:

Description

Port Number |Check box to set corresponding port as port isolation, so that they can not forward data

Click "Save" to store and active settings.

5.3STP

The Spanning Tree Protocol (STP) can be used to detect and disable network loops, and to provide backup
links between switches, bridges or routers. This allows the switch to interact with other bridging devices in
your network to ensure that only one route exists between any two stations on the network, and provide
backup links which automatically take over when a primary link goes down.

5.3.1STP Bridge Settings

This page allows you to configure port STP settings. After Click "Advanced Configure" > "Spanning
Tree" > "Bridge Settings", followed screen will appear.

» Information & Status
» Network Admin
» Port Configure Basic Seitings
»PoE
wAdvanced Configure
= MAC Table
= VLANS
»Voice VLAN
»GVRP
»Port Isolation

STP Bridge Configuration

Protocol Version RSTP

Bridge Priority 32768 v
Hello Time 2

Forward Delay 15

Max Age 20

Maximum Hop Count
Transmit Hold Count

|S

= Loop Protection
wSpanning Tree

= Bridge Settings Advanced Settings

= MSTI Mapping
= MSTI Priorities
= CIST Poris
= MSTI Ports
»IPMC Profile
= MEP
=ERPS
»IGMP Snooping | Save || Reset |

Edge Port BPDU Filtering
Edge Port BPDU Guard

Port Error Recovery
Port Error Recovery Timeout

Figure 5-4 Spanning Tree Configuration



Screen Configuration object and description is:

Object Description

Click drop-down menu to select STP protocol version,
Protocol Version including: STP - Spanning Tree Protocol (IEEE802.1D);
RSTP - Rapid Spanning Tree Protocol (IEEE802.1w)

Controls the bridge priority. Lower numeric values have better priority. The
Bridge Priority bridge priority plus the MSTI instance number, concatenated with the 6-byte
MAC address of the switch forms a Bridge Identifier.

Forward Delay (4- |Forward Delay setting range is from 4 to 30 seconds. Default value is 15 seconds.
30)

The maximum age of the information transmitted by the Bridge when it is the

Max Age (6-40) Root Bridge. Valid values are in the range 6 to 40 seconds. Default value is 20 .

This defines the initial value of remaining Hops for MSTI information generated
atthe boundary of an MSTI region. It defines how many bridges a root bridge can
distribute its BPDU information. Valid values are in the range 6 to 40 hops.

Maximum Hop
Count (6-40)

The number of BPDU's a bridge port can send per second. When exceeded,
transmission of the next BPDU will be delayed. Valid values are in the range 1 to
10 BPDU's per second. Default value is 6.

Transmit Hold Count
(1-10)

Click "Save" to store and active settings.

5.3.2STP Bridge Port

After Click "Advanced Configure" > "Spanning Tree" > "Bridge Ports", followed screen will appear.

» Information & Status

Rt A s STP CIST Port Configuration

» Port Configure CIST Aggregated Port Configuratio
PROE STP S . Restricted Point-to-
+Advanced Configure Port . bled Path Cost Priority Admin Edge Auto Edge Role TCN BPDU Guard point
=MAC Table = v Auto v 128 v Non-Edge ¥ v Forced True ¥
= VLANS
»Voice VLAN =
»GVRP CIST Normal Port Configuration
»Port Isolation STP L 2 Restricted Point-to-
SR Port Enabled Path Cost Priority Admin Edge Auto Edge Role TCN BPDU Guard point
wSpanning Tree x v <> v <> v <> v v <> v
= Bridge Settings 1 Auto ¥ 128 Non-Edge ¥ v Auto v
= MSTI Mapping
- MSTI Priorities 2 Auto v 128 v Non-Edge v v Auto v
= CIST Ports 3 Auto v 128 v Non-Edge ¥ v Auto v
SR 4 Auto v 128 v| [Non-Edge v v Auto v
»IPMC Profile
MEP 5 v Auto v 128 v Non-Edge ¥ v Auto v
=ERPS 6 v Auto v 128 v Non-Edge v v Auto v
»IGMP Snooping

»IPV6 MLD Snooping
=LLDP

Save || Reset |

Figure 5-5 STP Configuration Screen



Configuration object and description is:

Object Description

STP Enabled Check to enable STP function.

Controls the path cost incurred by the port. The Auto setting will set the path cost
as appropriate by the physical link speed, using the 802.1D recommended values.
Using the Specific setting, a user-defined value can be entered. The path cost is
used when establishing the active topology of the network. Lower path cost ports
are chosen as forwarding ports in favour of higher path cost ports. Valid values are
in the range 1 to 200000000.

Controls the port priority. This can be used to control priority of ports having
identical port cost. (See above).

Path Cost(0=Auto)

Priority

Auto Edge Check box to set corresponding port as Auto Edge.

Restricted Role Check box to set corresponding port as Restricted Role

Restricted TCN Check box to set corresponding port as Restricted TCN

Check box to enable BPDU Guide. So when port receives BPDU reception, it will

BPDU Guide turn to Disable (Shut Down) status.

Controls whether the port connects to a point-to-point LAN rather than a shared
medium. This can be automatically determined, or forced either true or false.
Transition to the forwarding state is faster for point-to-point LANs than for shared
media. (This applies to physical ports only. Aggregations are always forced
Point2Point.

Point-to-point

Click "Save" to store and active settings.

5.4MAC Address Table

This page allows you to configure Mac address table settings. After Click "Advanced Configure" > "Mac
Table", followed screen will appear.

» Information & Status ) X
» Network Admin MAC Address Table Configuration
»Port Configure Aging Configuration
»PoE
wAdvanced Configure
= MAC Table
= VLANS
»Voice VLAN MAC Table Learning
»GVRP
»Port Isolation
= Loop Protection

Disable Automatic Aging

Aging Time 300 seconds

wSpanning Tree

= Bridge Settings
= MSTI Mapping
« MSTI Priorities Static MAC Table Configuration

= CIST Ports
«MSTI P‘:)rts Port Members
Delete VLANID MACAddress 1 2 3 4 5 6
»IPMC Profile

ludd Reaw Static Entry |

»IGMP Snooping Save | Reset
»IPV6 MLD Snooping z :

Figure 5-6 MAC Address Table Configuration



Screen Configuration object and description is:

Object Description

ADlsabIe_ If the box is checked, then the automatic aging function is disabled.
utomatic
Aging
The time after which a learned entry is
Aging Time discarded. Range: 10-1000000 seconds;
Default: 300 seconds.
This switch supports 3 types for MAC Table Learning
MAC Table 1. Auto: port will auto learn Mac address.
Learning 2. Disable: port will NOT learn MAC address.

3. Secure: port only forward data of configured static MAC address.

Static MAC Table
Configuration

The static entries in the MAC table are shown in this table. Click "Add New Static
Entry" to create a new record.

Click "Save" to store and active settings.

5.5 1GMP Snooping

Internet Group Management Protocol (IGMP) lets host and routers share information about multicast
groups memberships. IGMP snooping is a switch feature that monitors the exchange of IGMP messages
and copies them to the CPU for feature processing. The overall purpose of IGMP Snooping is to limit
the forwarding of multicast frames to only ports that are a member of the multicast group.

5.5.1Basic Configuration

After Click "Advanced Configure" > "IGMP Snooping" > "Basic Configuration”, followed screen will appear.

»Information & Status
» Network Admin

» Port Configure

»PoE
wAdvanced Configure

= MAC Table

= VLANS

»Voice VLAN

»GVRP

»Port Isolation

= Loop Protection

»Spanning Tree

»IPMC Profile

- MEP

= ERPS

wIGMP Snooping
= Basic Configuration
= VLAN Configuration
= Port Filtering Profile

»IPV6 MLD Snooping

«LLDP

» Security Configure

IGMP Snooping Configuration
Global Configuration

Snooping Enabled

Unregistered IPMCv4 Flooding Enabled v
IGMP SSM Range 232.0.0.0 /(8
Leave Proxy Enabled

Proxy Enabled

Port Related Configuration

& <> v
1 unlimited v
2 unlimited v
3 unlimited v
4 unlimited v
5 unlimited v
6

unlimited v

Figure 5-7 IGMP Snooping Basic Configuration



Configuration object and description is:

Object Description

Enable or disable the IGMP snooping. The default value is

Snooping "Disabled". Enable: check the box; Disable: do not check the box.

Enabled

Unregistered
IPMCv4 Flooding
Enabled

Check the box to enable unregistered IPMCv4 Flooding

Specify which ports act as router ports. A router port is a port on the
Ethernet switch that leads towards the Layer 3 multicast device or IGMP
querier.

If an aggregation member port is selected as a router port, the whole
aggregation will act as a router port.

Router Port

Fast leave performs deleting MAC forward entry immediately upon

Fast Leave . . ; \
receiving message for group de-registration

Click "Save" to store and active settings.

5.5.21GMP Snooping VLAN Configuration

After Click "Advanced Configure" > "IGMP Snooping" > "VLAN Configuration”, followed screen will appear.

»Information & Status
»Network Admin
»Port Configure Start from VLAN 1 with[20 | entries per page

IGMP Snooping VLAN Configuration Refresh || 1<< || >>

nooping Enabled Querier Election  Querier Address Compatibility PRI RV Ql (sec) QRI (0.1 sec) LLQI(0.1sec)
Delete 1 4 0.0.0.0| | IGMP-Auto MR 2| 125 100 10 1

Add New IGMP VLAN

»Port Isolation Save || Reset
= Loop Protection
»Spanning Tree
»IPMC Profile
=MEP
=ERPS
+IGMP Snooping
» Basic Configuration

« VLAN Configuration
= Port Fiftering Profile

Figure 5-7 IGMP Snooping VLAN

Configuration Configuration object and description is:

Object Description

Enable the per-VLAN IGMP Snooping. Up to 32 VLANs can be selected for

Snooping IGMP Snooping.

Enabled

Enable to join IGMP Querier election in the VLAN. Disable to act as an

Querier Election IGMP Non-Querier.

Define the IPv4 address as source address used in IP header for IGMP
Querier election. When the Querier address is not set, system uses IPv4
management address of the IP interface associated with this VLAN. When
the IPv4 management address is not set, system uses the first available IPv4
management address. Otherwise, system uses a pre-defined value. By
default, this value will be 192.0.2.1.

Click "Save" to store and active settings.

Querier Address
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5.6 ERPS

ERPS (Ethernet Ring Protection Switching), it integrates OAM function and APS protocol. If the ring
network was interrupted accidentally, the fault recovery times could be less than 50ms to quickly bring
the network back to normal operation. ITU-T G.8032 is the first industry standard for ERPS.

L

‘*‘\_ Note: Before enable ERPS, STP of ring port should be disabled. .

After Click "Advanced Configure" > "ERPS", followed screen will

appear.

»Information & Status
»Network Admin
»Port Configure Delete RingID EastPort WestPort Ring Type Interconnected Node Major RRing ID Alarm
»PoE Delete | 2 1 1 Sub v 0 [
~Advanced Configure

= MAC Table Add New Ring Group Save || Reset

=VLANS

»Voice VLAN

»GVRP

»Port Isolation

Ethernet Rapid Ring Protection Switching Refresh

«Loop Protection
»Spanning Tree

MIPMC Profile
=MEP
=ERPS

Figure 5-8 EPRS

Configuration Configuration object and description is:

Object Description

Ring ID ERPS Ring ID
East Port Number of the port which participate in this Ring protection.
West Port Number of the other port which participate in this Ring protection.

Available selection: ""Major Ring"' or "'Sub Ring"'.

Only in case of Multi Ring application, ''Sub Ring" is required to configure.
Default Ring Type: '""Major Ring". Only if there is multi ring application, it is
required to set.

Ring Type

In Multi Ring application, Interconnected Node is the node that connect 2 or

Interconnected Node .
more rings.

In Single Ring application, Major Ring ID is same as Ring ID.

Major Ring ID In Multi Ring application, Sub Ring has to be type as Major Ring ID.

R-APS VLAN(1-4094) |Define VLAN for R - APS VLAN.

Click "Add New Ring Group" to create a new ERPS ring

application. Click "Save" to store and active settings.



After click the number under "Ring ID", it will go to the page for Ring Configuration as followed screen:

}information & Status.
»Network Admin
»Port Configure Instance Data

Rapid Ring Configuration 2 Auto-refresh  Refresh |

»PoE
vAdvanced Configure
=MAC Table

Ring ID EastPort WestPort East Port SF MEP West Port SF MEP East Port APS MEP West Port APS MEP  Ring Type
2 3 4 B 4 3 4 Sub Ring

= VLANS Instance Configuration

»Voice VLAN

»GVRP Configured WTR(Wait to Restore) Time Revertive VLAN config
»Port Isolation f 1min v v VLAN Config
alopo Ergiachon) RPL Configuration

»Spanning Tree

MPMC Profile RPL Role RPL Port  Clear

«MEP None v || None

=ERPS

»IGMP Snooping Sub-Ring Configuration

PV6 MLD Snooping
«LLDP

» Security Configure

»QoS Configure Instance State

»Diagnostics

»Maintenance

Ring Type Topology Change
Sub Ring

Protected SF SF SF DNF BPRO 0 [ Blocked Blocked

Save || Reset

Figure 5-9 EPRS Ring Configuration

Configuration object and description is:

Object Description

Click drop-down menu to select WTR time for R-APS. Available
selection: 1-12min
Default: 1 min

WTR(Wait to
Restore) Time(1-12)

Revertive Check to enable Revertive status of R-APS.

VLAN After clicked "VLAN config", it will go the page of Rapid Ring VLAN

config Configuration.
RPL Role Click drop-down menu to select "None", ""RPL Owner", or "RPL Neighbor" role.
RPL Port Click drop-down menu to select "'"None", ""East Port", or '"West Port".

Click "Save" to store and active settings.

After clicked "VLAN config'’, it will go the page of Rapid Ring VLAN Configuration as following screen:

» Information & Status s . ) ]
» Network Adwin Rapid Ring VLAN Configuration 2

» Port Configure Delete VLANID
» POoE 1

wAdvanced Configure ' ‘
= MAC Table | Add New Entry || Back |

= VLANS
»Voice VLAN L Save || Resetv’
»GVRP

Figure 5-10 Rapid Ring VLAN Configuration

Click "Add New Entry" to create a new entry. Click "Save" to store and active settings.




5.7LLDP

Link Layer Discovery Protocol (LLDP) is used to discover basic information about neighboring
devices on the local broadcast domain. LLDP is a Layer 2 protocol that uses periodic broadcasts to
advertise information about the sending device. Advertised information is represented in Type
Length Value (TLV) format according to the IEEE 802.1ab standard, and can include details such as
device identification, capabilities and configuration settings. LLDP also defines how to store and
maintain information gathered about the neighboring network nodes it discovers.

After Click "Advanced Configure" > "LLDP", followed screen will appear.

pInformation & Status

ek LLDP Configuration
» Port Configure LLDP Parameters
»PoE : -
+Advanced Configure Tx Interval ‘730 seconds
= MAC Table Tx Hold 4 times
= VLANS TxDelay |H seconds
»Voice VLAN i B : .
»GVRP x Rein 7 | seconds
»Port Isolation LLDP Interface Configuration
= Loop Protection
»Spanning Tree Optional TLVs
»IPMC Profile Interface _ Mode  PortDescr Sys Name SysDescr SysCapa MgmtAddr
«MEP % <> v | 2 v 2 7] |
= ERPS GigabitEthernet 1/1 | Enabled v | v v v v v
I gy GigabitEthernet 1/2 | Enabled ¥ % | T ) i
P AN Suoneieg GigabitEthernet 1/3 | Enabled ¥ | v v v v 7
s 'LL_DPC 1 GigabitEthernet 1/4 | Enabled v | o v 7 v 7l
it et GigabitEthernet 1/5 | Enabled v v v v v v
» QoS Configure Sy ‘ =
k f GigabitEthernet 1/6 | Enabled v | 4 v 4 v 4
» Diagnostics —

» Maintenance

| Save;] | Reseti\

Figure 5-10 LLDP Configuration

Screen Configuration object and description is:



Object Description

Here allows the user to inspect and configure the current LLDP port settings:
» Tx Interval: Transmission Interval Time

LLDP Parameters » Tx Hold: Hold time Multiplier

» Tx Delay: Transmit Delay Time

» Tx Remit: Transmit Remit Time

Select LLDP messages transmit and receive modes for LLDP Protocol Data

Mode Units. Options are Tx only, Rx only, Enabled, and Disabled.

To configure the information included in the TLV field of advertised
messages. When followed option is checked, corresponding information
will be includedin LLDP information transmitted.

» Port Descr: Port Description
Optional TLVs » Sys Name: System Name

»  Sys Descr: System Description

» Sys Capa: System Capability

» Mgmt Addr: Management Address

Click "Save" to store and active settings.



5.8 Loop Protection

Loop protection is to avoid broadcast loops. After Click "Advanced Configure" > "Loop Protection" ,
followed screen will appear.

pInformation & Status . - v
Loop Protection Configuration
» Network Admin P g

» Port Configure General Settings

»PoE

wAdvanced Configure
= MAC Table
= VLANs
»Voice VLAN

»GVRP

»Port Isolation Port Configuration
= Loop Protection Port Enable Action Tx Mode

Global Configuration
Enable Loop Protection QEVEELICRS
Transmission Time 5 seconds

Shutdown Time 180 seconds

»Spanning Tree = wl &% vi|l<s v
HIEMC Frome 1 v Shutdown Port v | Enable v "
::‘Egs 2 4 Shutdown Port and Log ¥ | | Enable v
»IGMP Snooping 3 ¥ Log Only v |Enable ¥
»IPV6 MLD Snooping 4 v Shutdown Port v Enable v
«LLDP 5 v Shutdown Port v | Enable v
» Security Configure 6 v 'VShutdqwn Port v || Enable v |

» QoS Configure
p Diagnostics [

| Save || Reset |

» Maintenance

Figure 5-11 Loop Protection Configuration

Screen Configuration object and description is:

Object Description

Enable Loop Protection: click drop-down menu to disable or enable Loop
Protection;

Transmission Time: enter a number to set Loop Protection Interval Time;
Shutdown Time: enter a number to set port Shutdown Time.

Global
Configuration

Enable Check to enable corresponding port loop protection.

Action take when the port detected loop. There are 3 types of action for

Action users to select, Shutdown port, Shutdown port and Log, Log Only.

Tx Mode To enable or disable Tx.

Click "Save" to store and active settings.



6. QoS Configure

Quality of Service (QoS) is an advanced traffic prioritization feature that allows you to establish control over
network traffic. QoS enables you to assign various grades of network service to different types of traffic,
such as multi-media, video, protocol-specific, time critical, and file-backup traffic. This function n can not

only reserve bandwidth, but also limit other traffic that is not so important.

6.1 QoS Port Classification

After Click "QoS Configure" > "Port Classification"”, followed screen will appear.

p Information & Status AT 5
SRtk A QoS Ingress Port Classification

» Port Configure Port CoS DPL PCP DEI TagClass. DSCP Based Address Mode

» POE "<>v‘j<>v:‘<>v‘<>vr‘ <z v
» Advanced Configure 1 [ov] [ov] [0 1v Disabled J 'Source v
» Security Configure ~ R4 ERd EEd [E Disabled  Destination v
v QoS Conﬁgute : 3 [2v] [ov] [2v] [O¥ Disabled 'Source v
« Port Classification 4 [3v| [0v| [3v|[0v| Disabled O
= Port Policing = 5 = ) ‘
= Queue Policing 5 0' 0v| [0v] [0v| Disabled  Source Y|
= Port Scheduler 6 [0v| [0v| ([0¥| (O Disabled ‘ 'Source v
= Port Shaping 3
= Port Tag Remarking | Save || Reset |

= Port DSCP

= DSCP-Based QoS

= DSCP Translation

= DSCP Classification
= QoS Control List

= Storm Policing

Figure 6-1 Port Classification Configuration Screen



Configuration object and description is:

Object Description

Controls the default class of service, ranging from 0 (lowest) to 7 (highest).

All frames are classified to a CoS. There is a one to one mapping between
CoS, queue and priority. A CoS of 0 (zero) has the lowest priority

CoS
The classified CoS can be overruled by a QCL entry.

Note: If the default CoS has been dynamically changed, then the actual default
CoS is shown in parentheses after the configured default CoS.

Controls the default drop precedence level.
DPL All frames are classified to a drop precedence level.
The classified DPL can be overruled by a QCL entry.

Controls the default PCP value.
All frames are classified to a PCP value.

PCP If the port is VLAN aware and the frame is tagged, then the frame is classified to
the PCP value in the tag. Otherwise the frame is classified to the default PCP
value.

Controls the default DEI value.
DE| All frames are classified to a DEI value.

If the port is VLAN aware and the frame is tagged, then the frame is classified to
the DEI value in the tag. Otherwise the frame is classified to the default DEI
value.

The IP/MAC address mode specifying whether the QCL classification must be
based on source (SMAC/SIP) or destination (DMAC/DIP) addresses on this port.
Address Mode |The allowed values are:

Source: Enable SMAC/SIP matching.

Destination: Enable DMAC/DIP matching.

Click "Save" to store and active settings.



6.2 Port Policing

After Click "QoS Configure" > "Port Policing", followed screen will appear.

» Information & Status

QoS Ingress Port Policers

» Network Admin
» Port Configure Port Enable Rate Unit Flow Control
» PoE * ‘ 500/ |<> v
» Advanced Configure 1 v 500, |kbps ¥ v
» Security Configure 2 5 500/ |Mbps ¥
QoS Configure 3 ¢ ' 500 [fps v v
= Port CIa_s;gﬁcatuon 4 ' 500 kips v
= Port Policing 7
= Queue Policing 5 500 |kips ¥
= Port Scheduler 6 500/ |kfps v
= Port Shaping
= Port Tag Remarking | Save || Reset |

= Port DSCP
Figure 6-2 Port Policing Configuration Screen

Configuration object and description is:

Object Description

Enabled Check the box to enable Port Policing.

Controls the rate for the policer. The default value is 500. This value is restricted
Rate to 100-1000000 when the "Unit" is "kbps" or "fps", and it is restricted to 1-3300
when the "Unit" is "Mbps" or "kfps".

Controls the unit of measure for the policer rate as kbps, Mbps, fps or kfps .

Unit The default value is "kbps".

If flow control is enabled and the port is in flow control mode, then pause frames

Flow Control are sent instead of discarding frames.

Click "Save" to store and active settings.

6.3 Storm Control Configuration

After Click "QoS Configure" > "Storm Control", followed screen will appear.



pInformation & Status
p Network Admin
» Port Configure

Global Storm Policer Configuration

Frame Type Enable Rate

»PoE Unicast 1 |fps ¥
» Advanced Configure Multicast d | 1024 [Kips v
» Security Configure Broadcast 5 » 256 kfps v

v QoS Configure
= Port Classification | Save || Reset |
= Port Policing
= Queue Policing
= Port Scheduler
= Port Shaping
= Port Tag Remarking
= Port DSCP
= DSCP-Based QoS
= DSCP Translation
= DSCP Classification
= QoS Conirol List
= Storm Policing

Figure 6-3 Port Policing Configuration Screen

Configuration object and description is:

Object Descriptio
n
Frame Type This switch supports 3 kinds of Frame Type: Unicast, Unknown Multicast,
Broadcast.
Enable Check the box to enable Storm Control.
Rate(pps) The rate unit is packets per second (pps). Valid values are: 1, 2, 4, 8, 16, 32, 64,
PP 128, 256, 512, 1K, 2K, 4K, 8K, 16K, 32K, 64K, 128K, 256K, 512K or 1024K..

Click "Save" to store and active settings.



7. Security Configure

7.1 Password

To change system login password of the switch, please click "Security Configure" > "Users" > press the User
you want to change.

»Information & Status
» Network Admin
» Port Configure

Users Configuration

User Name Privilege Level
» POE admin 15

p Advanced Configure
w Security Configure
= Users

,7 Add New User |

»Information & Status
» Network Admin

» Port Configure

» PoE

» Advanced Configure

Edit User

User Settings
User Name 1admin

Password seeee

w Security Configure

Password (again) |G
= Users

= Privilege Levels

= SSH — — =
«HTTPS | Save || Reset || Cancel |

4
!

5

Privilege Level

Figure 7-1 System Password Configuration Screen

Click "Save" to store and active settings.

7.2 802.1X

In the 802.1X-world, the user is called the supplicant, the switch is the authenticator, and the RADIUS server
is the authentication server. The switch acts as the man-in-the-middle, forwarding requests and responses
between the supplicant and the authentication server. Frames sent between the supplicant and the switch
are special 802.1X frames, known as EAPOL (EAP over LANs) frames. EAPOL frames encapsulate EAP PDUs
(RFC3748). Frames sent between the switch and the RADIUS server are RADIUS packets.

RADIUS packets also encapsulate EAP PDUs together with other attributes like the switch's IP address, name,
and the supplicant's port number on the switch. EAP is very flexible, in that it allows for different
authentication methods, like MD5-Challenge, PEAP, and TLS. The important thing is that the authenticator
(the switch) doesn't need to know which authentication method the supplicant and the authentication server
are using, or how many information exchange frames are needed for a particular method. The switch simply
encapsulates the EAP part of the frame into the relevant type (EAPOL or RADIUS) and forwards it.



When authentication is complete, the RADIUS server sends a special packet containing a success or failure
indication. Besides forwarding this decision to the supplicant, the switch uses it to open up or block traffic
on the switch port connected to the supplicant.

The IEEE 802.1X standard defines a client-server-based access control and authentication protocol that
restricts unauthorized clients from connecting to a LAN through publicly accessible ports. The authentication
server authenticates each client connected to a switch port before making available any services offered by
the switch or the LAN.

Until the client is authenticated, 802.1X access control allows only Extensible Authentication Protocol over
LAN (EAPOL) traffic through the port to which the client is connected. After authentication is successful,
normal traffic can pass through the port.

This switch supports 802.1X port-based authentication. In this page, user can configure 802.1X. After click
"Security Configure" > "802.1X", followed screen will appear.

»Information & Status

ok Kk Network Access Server Configuration

» Port Configure System Configuration

»PoE

»Advanced Configure Mode Disabled E

+ Security Configure Reauthentication Enabled
i Reauthentication Period _3600 seconds
= Privilege Levels EAPOL Timeout 30 seconds
=SSH Aging Period 300 seconds
sHIEES Hold Time 10 | seconds

= Port Security Limit

= Access Management
=802.1X

»ACL

»DHCP

»IP&MAC Source Guard

»ARP Inspection
PAAA
»QoS Configure
» Diagnostics
»Maintenance

RADIUS-Assigned QoS Enabled
RADIUS-Assigned VLAN Enabled
Guest VLAN Enabled

Guest VLAN ID

Max. Reauth. Count

Allow Guest VLAN if EAPOL Seen

Port Configuration

Admin State

RADIUS-Assigned RADIUS-Assigned

Port State

<> v

QoS Enabled

1 |Force Authorized v Globally Disabled | Reauthenticate ||

2 |Force Authorized v Globally Disabled | Reauthenticate |

3 | Force Authorized v Globally Disabled | Reaut

4 |Force Authorized v Globally Disabled | Reauthenticate |

5 |Force Authorized v Globally Disabled | Reauthenticate || Reinitialize |
6 |Force Authorized v Globally Disabled | Reauthenticate || Reinitialize

Save || Reset |

Figure 7-2 802.1X Configuration

Screen Configuration object and description is:

Object Description

Here, user can enable or disable 802.1X or Reauthentication, as well as

System
Configuration

set Reauthentication Period / EAPOL Timeout / Aging Period / Hold

Time

Port
Configuration

Click drop-down menu to select an Admin State. Available options: Force

Authorized, Force Unauthorized, 802.1X, Mac-based Auth.

Click "Save" to store and active settings.



7.3 DHCP Snooping
7.3.1DHCP Overview

DHCP protocol is widely used to dynamically allocate reusable network resources, such as IP address. A
typical process of DHCP to obtain IP is as following:

DHCP Server

DHCP Client

i N
u F

L SRTEE R e L L L LT L L L L L L e e e e e e L L LT LT LL L LR LR s »
i1
; 2. DHCPOFFER

T T »
T 3. DHCPREGQUEST

4. DHCPACK

DHCP Client sent DHCP DISCOVER message to DHCP Server, if Client did not receive respond from server
within a period of time, it will resend DHCP DISCOVER message.

After received DHCP DISCOVER message, DHCP Server will assign sources (IP address for example) to client,
and then send DHCP OFFER message to DHCP Client.

After received DHCP OFFER message, DHCP Client send DHCP REQUEST to ask for server lease, and notify
the other servers that it has accepted this server to assign addresses.

After received DHCP REQUEST, server will verify whether resource can be allocated. If OK, it will send DHCP
ACK message; If not OK, it will send DHCP NAK message. After received DHCP ACK message, start using the
source which server assigned. If received DHCP NAK, DHCP Client will resend DHCP DISCOVER message.

7.3.2 About DHCP Snhooping

The addresses assigned to DHCP clients on insecure ports can be carefully controlled using the dynamic
bindings registered with DHCP Snooping. DHCP snooping allows a switch to protect a network from rogue
DHCP servers or other devices which send port-related information to a DHCP server. This information can
be useful in tracking an IP address back to a physical port.

Command Usage

> Network traffic may be disrupted when malicious DHCP messages are received from an outside
source. DHCP snooping is used to filter DHCP messages received on a non-secure interface from
outside the network or firewall When DHCP snooping is enabled globally and enabled on a VLAN
interface, DHCP messages received on an untrusted interface from a device not listed in the DHCP
snooping table will be dropped

» Table entries are only learned for trusted interfaces. An entry is added or removed dynamically to the
DHCP snooping table when a client receives or releases an IP address from a DHCP server. Each entry
includes a MAC address, IP address, lease time, VLAN identifier, and port identifier.

» When DHCP snooping is enabled, DHCP messages entering an untrusted interface are filtered based
upon dynamic entries learned via DHCP snooping.



» If a DHCP packet from a client passes the filtering criteria, it will only be forwarded to trusted
ports in the same VLAN
> If a DHCP packet is from server is received on a trusted port, it will be forwarded to both
trusted and untrusted ports in the same VLAN.
>  If the DHCP snooping is globally disabled, all dynamic bindings are removed from the binding table.

7.3.3DHCP Snooping Configure

After click "Security Configure' > "DHCP " > "Snooping Setting"', following screen will appear.
» Information & Status

DHCP Snooping Configuration

» Network Admin
» Port Configure Snooping Mode RESLEIIET R
» PoE
p Advanced Configure
v Security Configure Port Mode Configuration
= Users
= Privilege Levels Port Mode
=« SSH * <> v
. :TJPS L 1 |Trusted v
g Lafoly 2 | Untrusted v
= Access Management —
=802 1X 3 | Trusted v
»ACL 4 Untrusted v
wDHCP 5 Trusted v
= Snooping Setting 6 | Trusted v

= Snooping Table
= Relay

= Relay Statistics B
= Detailed Statistics

Save || Reset |

Figure 7-3 DHCP Snooping Configuration Screen

Configuration object and description is:

Object Description

DHCP Snooping Click drop-down menu to enable or disable DHCP Snooping
Mode

Indicates the DHCP snooping port mode. Possible port modes are:

Port Mode Trusted: Configures the port as trusted source of the DHCP

messages.

Untrusted: Configures the port as untrusted source of the DHCP messages.

Click "Save" to store and active settings.



7.41P&MAC Source Guard

IP&MAC Source Guard is a secure feature used to restrict IP traffic on DHCP snooping untrusted ports by
filtering traffic based on DHCP Snooping Table or manually configured IP Source Bindings. It helps
prevent IP spoofing attacks when a host tries to spoof and use the IP address of another host.

7.4.1Port Configuration

In this page, user can make IP&MAC Source Guard Port Configuration. After click "'Security
Configure'>"IP & MAC Source Guard" >"Configuration”, followed screen will appear.

»Information & Status . .
IP Source Guard Configuration

pDHCP
wIP&MAC Source Guard
= Configuration

= Static Table
= Dynamic Table

DN AW N -

' Disabled v || Unlimited

Disabled v | Unlimited
Disabled ¥ || Unlimited

» Network Admin

» Port Configure [\ Gl | Disabled v

» POE

» Advanced Configure | Translate dynamic to static |

w Security Configure
= Users
= Privilege Levels Port Mode Configuration
=« SSH
«HTTPS Port Mode Max Dynamic Clients
= Port Security Limit =8l <% v | v
= ACCess Managesment Disabled ¥ || Unlimited v
=802 1X AT e
»ACL Disabled v | Unlimited v

Disabled ¥ || Unlimited v

»ARP Inspection

| Save || Reset |

Figure 7-4 IP&RMAC Guard- Port Configuration Screen

Configuration object and description is:

Object Description

Global Mode Click drop-down menu to enable or disable Global IP&KMAC Source Guard
function
Click drop-down menu to enable or disable the IP&RMAC Source Guard
Port Mode

function for corresponding port.

Click drop-down menu to select Max Dynamic Clients. Available options:

Max Dynamic Clients Unlimited, 0, 1, 2.

Click "Save" to store and active settings.



7.4.2Static Table

In this page, user can manually set Static Table of IPRMAC Guard to fulfill controlling function to port.
After click "Security Configure">"IP&MAC Source Guard" >''Static Table", followed screen will appear.

»Information & Status :
» Network Admin Static IP Source Guard Table

» Port Configure Delete Port VLANID IP Addess MAC address
» PoE x Delete | (17

p Advanced Configure
w Security Configure | Add New Entry |

= Users
= Privilege Levels | Save || Reset |
=« SSH

« HTTPS

= Port Security Limit

= Access Management
= 802.1X

pACL

»DHCP

wIP&MAC Source Guard

= Configuration
= Static Table

Figure 7-5 Static Table Configuration Screen

Configuration object and description is:

Object Description

Port Click drop-down menu to select which port should be fixed.
VLAN Type VLAN ID that should be fixed to
IP Address Type IP Address that should be fixed to
MAC Address Type Mac Address that should be fixed to

Click ""Add New Entry'' button to create a new

record. Click "Save" to store and active settings.

7.5 ARP Inspection

Dynamic ARP Inspection (DAI) is a secure feature. Several types of attacks can be launched against a host or
devices connected to Layer 2 networks by "poisoning” the ARP caches. This feature is used to block such
attacks. Only valid ARP requests and responses can go through DUT. A Dynamic ARP prevents the untrust
ARP packets based on the DHCP Snooping Database. This page provides ARP Inspection related configuration.



7.5.1Port Configuration

User can make port configuration in this page. After click "'Security Configure'>"ARP Inspection"
>""Port Configuration", followed screen will appear.

EOn & s ARP Inspection Configuration

» Network Admin
» Port Configure Mode
»PoE
» Advanced Configure | Translate dynamic to static |
w Security Configure
= Users
'gg\ll:ege Levels Port Mode Configuration
«HTTPS Port Mode Check VLAN Log Type
= Port Secunty Limit g v <> v <> v

= Access Management
=802 1X
pACL
»DHCP
»IP&MAC Source Guard
+ARP Inspection
= Port Configuration
= VLAN Configuration _
» Static Table Save || Reset |
= Dynamic Table

Disabled v Disabled v None v
‘Disabrled v Disabled ¥ None ¥
Disabled v Disabled v None v
Disabled ¥ Disabled v None v
Disabled v | |Disabled ¥| |None ¥
Disabled v Disabled v None v

Lo B o N & N

Figure 7-6 ARP Inspection Port Configuration

Screen Configuration object and description is:

Object Description

Global Mode Click drop-down menu to enable or disable Global ARP Inspection

Port Mode Click drop-down menu to enable or disable port-based ARP Inspection

If you want to inspect the VLAN configuration, you have to enable the setting
of "Check VLAN". The default setting of "Check VLAN" is disabled. When the
setting of "Check VLAN" is disabled, the log type of ARP Inspection will refer to

Check VLAN the port setting. And the setting of "Check VLAN" is enabled, the log type of
ARP Inspection will refer to the VLAN setting. Possible setting of "Check VLAN"
are:

Enabled: Enable check VLAN
operation. Disabled: Disable check
VLAN operation.

Only the Global Mode and Port Mode on a given port are enabled, and the
setting of "Check VLAN" is disabled, the log type of ARP Inspection will refer to
the port setting. There are four log types and possible types:

Log Type None: Log nothing.

Deny: Log denied entries.

Permit: Log permitted

entries. ALL: Log all entries.

Click "Save" to store and active settings.



7.5.2VLAN Configuration

After click "Security Configure'>"ARP Inspection' >"VLAN Configuration", followed screen will appear.

»Information & Status VLAN Mode Configuration

» Network Admin
»Port Configure Start from VLAN |1 with |20 entries per page.
»PoE
»Advanced Configure Delete VLANID Log Type
w Security Configure | Delete | 1 None v
= Users S i
= Privilege Levels | Add New Entry |
= SSH
«HTTPS | Save || Reset |

= Port Security Limit

= Access Management
= 802.1X

»ACL

»DHCP

»IPE&MAC Source Guard
wARP Inspection
= Port Configuration
= VLAN Configuration
= Siatic Table
= Dynamic Table

Figure 7-8 ARP Inspection VLAN Configuration Screen

Configuration object and description is:

Object Description

VLAN ID Indicates the ID of this particular VLAN

Click drop-down menu to enable or disable port-based ARP Inspection.
Specify ARP Inspection is enabled on which VLANSs. First, you have to enable the
port setting on Port mode configuration web page. Only when both Global
Mode and Port Mode on a given port are enabled, ARP Inspection is enabled
on this given port. Second, you can specify which VLAN will be inspected on
Log Type VLAN mode configuration web page. The log type also can be configured on
per VLAN setting.

Possible types are:

None: Log

nothing.

Deny: Log denied entries.

Permit: Log permitted

entries. ALL: Log all entries.

Click "Add New Entry" button to create a new record of VLAN configuration. Click "Save" to store
and active settings.



7.5.3Static Table

User can manually configure ARP Inspection Static Table to control port. After click "'Security
Configure''>"ARP Inspection' >''Static Table", followed screen will appear.

pInformation & Status = .
» Mietwork Adenin Static ARP Inspection Table

» Port Configure Delete Port VLANID MAC Address IP Address
»PoE | Delete | [1v

p Advanced Configure

w Security Configure | Add New Entry |
= Users . i
= Privilege Levels | Save || Reset |
= SSH
=« HTTPS

= Port Security Limit

= Access Management
= 802.1X

pACL

»DHCP

»IPEMAC Source Guard
w+ARP Inspection
= Port Configuration
= VLAN Configuration
= Stafic Table
= Dynamic Table

Figure 7-9 Static Table Configuration Screen

Configuration object and description is:

Object Description

Port Click drop-down menu to select which port should be fixed.
VLAN Type VLAN ID that should be fixed to
IP Address Type IP Address that should be fixed to
MAC Address Type Mac Address that should be fixed to

Click ""Add New Entry'' button to create a new record. Click "Save" to store and active settings.

7.6 ACL

ACL is an acronym for Access Control List. It is the list table of ACEs, containing access control entries
that specify individual users or groups permitted or denied to specific traffic objects, such as a process or a
program. Each accessible traffic object contains an identifier to its ACL. The privileges determine whether
there are specific traffic object access rights.



ACL implementations can be quite complex, for example, when the ACEs are prioritized for the various
situation. In networking, the ACL refers to a list of service ports or network services that are available on a
host or server, each with a list of hosts or servers permitted or denied to use the service. ACL can generally
be configured to control inbound traffic, and in this context, they are similar to firewalls.

7.6.1 ACL Ports Configure

After click "'Security Configure''>"ACL" >''Ports", followed screen will appear.

»information & Status

ACL Ports Configuration

» Network Admin
»Port Configure Port PolicyID  Action Rate LimiterID EVC Policer EVC Policer ID  Port Redirect Mirror
»PoE Disabled
»Advanced Configure - 0 <> v <> v <> v 1 Port 1 <> v o v| [« v| [<
v Security Configure Port2  ~
el Disabled
- Priviege Levels 1 0 [Permit v Disabled v| | Disabled v 1 Port 1 Disabled v | |Disabled v| [Disabled v| [Enabled v| 478486
«SSH Port2 ~
«HTTPS Disabled
» Port Security Limit 2 0| |Permit v Disabled ¥ Disabled v 1 Port 1 Disabled ¥ Disabled ¥ Disabled ¥ Enabled v 0
» Access Management Port2 ~
=802.1X Disabled
wACL 3 0 |Permit v Disabled ¥ Disabled ¥ 1 Port 1 Disabled ¥ Disabled ¥ Disabled ¥ Enabled v 0
= Ports Port2 v
= Rate Limiters Disabled
= Access Control List 4 0| |Permit v Disabled ¥ Disabled v 1 Port 1 Disabled ¥ Disabled v Disabled v Enabled v 0
»DHCP Port2 ~
»IP&MAC Source Guard Disabled
<ARP Inspection 5 0| [Permit v Disabled ¥ Disabled ¥ 1 Port 1 Disabled v | [Disabled v | [Disabled v| |Enabled v 0
= Port Configuration bort2 %
« VLAN Configuration Disabled
« Static Table 6 0| |Permit v Disabled ¥ Disabled v 1 Port 1 Disabled ¥ Disabled ¥ Disabled v Enabled v 0
« Dynamic Table Port2 ~

PAAA
Save || Reset

»QoS Configure

Figure 7-10 ACL Ports Configuration Screen

Configuration object and description is:

Object Description

There are 2 available options:
Action Permit: that specific port allows data going through.
Deny: that specific port forbid data going through.

Rate Limiter

D Port’s fixed Rate Limiter ID, please go to Rate Limiter Configuration for more details.

Select which port frames are redirected on. The allowed values are Disabled or a
specific port number and it can't be set when action is permitted. The default value
is "Disabled".

Specify the mirror operation of this port. The allowed values

are: Enabled: Frames received on the port are mirrored.

Port Redirect

Mirror Disabled: Frames received on the port are not
mirrored. The default value is "Disabled”.

Logging Enabled or Disabled Log
Specify the port shut down operation of this port. The allowed
values are: Enabled: If a frame is received on the port, the port will
be disabled.

Shut Down

Disabled: Port shut down is disabled.

The default value is "Disabled".

Note: The shutdown feature only works when the packet length is less than 1518
(without VLAN tags).

Specify the port state of this port. The allowed values are:

Enabled: To reopen ports by changing the volatile port configuration of the

State ACL user module.

Disabled: To close ports by changing the volatile port configuration of the ACL user
module. The default value is "Enabled".

Counter Counts the number of frames that match this rule.

Click "Save" to store and active settings.



7.6.2Rate Limiter Configuration

User can make ACL Rate limiter configuration in this page. After click ""Security Configure'>"ACL"
>'"Rate Limiter", followed screen will appear.

pInformation & Status

ACL Rate Limiter Configuration

» Network Admin
» Port Configure Rate Limiter ID Rate Unit
»PoE * 1 |<> v
» Advanced Configure 1 [ 1 lpps v/
v Security Configure 2 1 pps v
= Users 3 1| ppS v
= Privilege Levels — = '
« SSH 4 AfSipps v |
«HTTPS 5 1 |pps 7|
= Port Security Limit 6 1| | pps v |
= Access Management 7 *1- :Vpps —
= 802.1X 1 '
vACL & 1 [pps ¥
= Ports 9 1 ipps ¥
= Rate Limiters 10 1 |pps ¥ |
= Access Control List 1 1 pps v
»DHCP 12 Al Tpps v|
»IP&MAC Source Guard 13 1| | pps v |
»ARP Inspection o .
14 1 |pps v
PAAA —
15 1 |pps ¥ |
» QoS Configure 16 1 ‘Vpps =

p Diagnostics
» Maintenance

| Save || Reset |

Figure 7-11 ACL Rate Limiters Configuration

Screen Click "Save" to store and active settings.

7.6.3 Access Control List Configuration

User can make Access Control List Configuration in this page . After click ''Security Configure"
> "ACL" >"Access Control List", followed screen will appear.

»information & Status
»Network Admin
»Port Configure
»POE
»Advanced Configure
w Security Configure
=Users
= Privilege Levels
=SSH
=HTTPS

Access Control List Configuration Auto-refresh [/ | Refresh || Crlearr Remove All |

ACE Ingress Port Policy / Bitmask Frame Type Action Rate Limiter Port Redirect Mirror Counter

« Port Security Limit
= Access Management

=802.1X
wACL
=Ports
Rate Limiters
= Access Control List

Figure 7-12 Access Control List Configuration Screen

Click @ button, to go to Access Control List, and edit it.




8. Diagnostics

8.1Ping Test

Ping is a little program that can issue ICMP Echo packets to the IP address you defined. Destination
node will respond to those packets sent from switch. So Ping test is to troubleshoot IP connectivity

issues.

After click ""Diagnostics ''>''Ping'’, followed screen appear.

pInformation & Status

» Network Admin MEREg

» Port Configure IP Address  0.0.0.0
»PoE Ping Length 56

» Advanced Configure Ping Count 5

w Security Configure
= Users
= Privilege Levels Start
« SSH '

Ping Interval |1

«HTTPS
= Port Security Limit
= Access Management

=802 1X
wACL

= Ports
= Rate Limiters
= Access Conirol List

» DHCP
»IP&MAC Source Guard
»ARP Inspection
PAAA
» QoS Configure
w Diagnostics
= Ping

Figure 8-1 Ping Test Screen

Configuration object and description is:

Object Description

IP Address The destination IP Address that needed to Ping
Ping Length Input a number between 1 and 1452. Default: 56
Ping Count The times for inputting Ping IPv4 address or IPv6 address (Number of echo
requests to send). User can input a number between 1 and 60.
Ping Interval | Interval time for Ping (Send interval for each ICMP packet)

Click ""Start" button to start Ping testing.



8.2 Cable Diagnostics

The Cable Diagnostics performs tests on 10/100/1000BASE-T copper cables. These functions have the ability
to identify the cable length and operating conditions, and to isolate a variety of common faults that can
occur on the Cat5 twisted-pair cabling.

After click "Diagnostics ''>''Cable Diagnostics'', followed screen will appear.

Piemation & ins VeriPHY Cable Diagnostics

» Network Admin

» Port Configure

»PoE ¢ .

» Advanced Configure J Start | .‘

» Security Configure

hONS Coama Cable Status

¥ Diagliosticy PairA LengthA PairB LengthB PairC LengthC PairD LengthD
g ; 1 OK 0 OK 0 OK 0 OK 0
= Cable Diagnostics 2 _ 0 = 0 = 0 - 0
= CPU Load A 0 - 3 = B -~ 0

»Maintenance 4 = 0 = 0 = 0 = 0

Figure 8-2 Cable Diagnostics Screen

Click ""Start" button to start ""Cable Diagnostics' testing.

8.3 CPU Load

This page shows percent of CPU load. After click "'Diagnostics'>""CPU Load", followed screen will appear.

CPU Load Refresh [
100ms 0% Isec 0% 10sec 0% (all numbers running average)
75%
50%
25%

Figure 8-3 CPU Load Screen



9. Maintenance

9.1 Restart Device

This page is for restarting switch. After click "Maintenance "'>''Restart Device'’, followed screen will appear.

»Information & Status
» Network Admin
»Port Configure

»PoE

»Advanced Configure
» Security Configure
»QoS Configure

Restart Device

Are you sure you want to perform a Restart?

| Yes | | No |

» Diagnostics
wMaintenance
= Restart Device
= Factory Defaulis
= Firmware Upgrade
= Firmware Select
»Configuration

Please click '"Yes' to restart the switch.

9.2 Factory Defaults

This page is for making all settings to factory defaults. After click "'"Maintenance ''>'"Factory Defaults",
followed screen will appear.

» Information & Status
» Network Admin

» Port Configure

»PoE

»Advanced Configure
» Security Configure

» QoS Configure

Factory Defaults

Are you sure you want to reset the configuration to

Factory Defaults?

» Diagnostics
wMaintenance
= Restart Device
= Factory Defaults
= Firmware Upgrade
= Firmware Select
»Configuration

[Yes] [N

Please click '"Yes" to reset the configuration to Factory Defaults.



9.3 Firmware Upgrade

This page is for upgrading system firmware. After click "Maintenance ''>''Firmware Upgrade", followed
screen will appear.

»Information & Status
» Network Admin

» Port Configure ' Datei auswahlen | Keine ausgewahit \ Upload
» POE

p Advanced Configure

» Security Configure

» QoS Configure

Software Upload

» Diagnostics
wMaintenance

= Restart Device

= Factory Defaults

= Firmware Upgrade
= Firmware Select

» Configuration

Please click "Browse" to select the firmware that needed to upgrade. And then click ""Upload " to start
upgrading.

9.4 Firmware Select

This page is for upgrading system firmware. After click "Maintenance ''>''Firmware Upgrade", followed
screen will appear.

pInformation & Status
» Network Admin

» Port Configure

»PoE

p Advanced Configure
» Security Configure

» QoS Configure

Software Image Selection

Active Image

Image  ALL-SGI8104PM_V4.0 dat
Version V2.1

Date 2019-07-12703:36:45-07:00

Alternate Image
Image  ALL-SGI8104PM_V3.0.dat

Version V2.1
Date 2019-07-10T03:18:38-07:00

p Diagnostics
v Maintenance
= Restart Device
= Factory Defaults
= Firmware Upgrade
= Firmware Select
» Configuration

}A Activate Alternate Image H Cancel |

Please click "Activate Alternate Image" to select the firmware.



9.5 Firmware Select

In this page, user can download, upload, activated or delete configuration files.

9.5.1Download Configuration File

After click ""Maintenance ">""Download", followed screen will appear.
»Information & Status
» Network Admin
» Port Configure Select configuration file to save.
»PoE
» Advanced Configure
» Security Configure
» QoS Configure - running-config
» Diagnostics defauli-config
wMaintenance  startup-config

= Restart Device . :
= Factory Defaults \ Download Configuration '
= Firmware Upgrade
= Firmware Select
w Configuration

= Download

= Acfivate

= Delete

Download Configuration

Please note: running-config may take a while to prepare for download.

Please choose a file and then click ""Download Configuration' button to download.

9.5.2Upload Configuration File

After click "Maintenance "'>"Upload", followed screen will appear. Then user can upload Configuration File.

»Information & Status
» Network Admin

» Port Configure File To Upload
» PoE

p Advanced Configure

» Security Configure Destination File
» QoS Configure
» Diagnostics
+Maintenance "’ running-config * Replace Merge
= Restart Device - startup-config
= Factory Defaults "' Create new file
= Firmware Upgrade g
= Firmware Select | Upload Configuration |
w Configuration
= Download
= Upload
= Activate
= Delete

Upload Configuration

| Datei auswahlen | Keine ausgewahit

File Name Parameters




9.5.3 Activate Configuration

After click "Maintenance ''>"Activate", followed screen will appear. Then user can activate Configuration
File.

» Information & Status
» Network Admin

Activate Configuration

»Port Configure Select configuration file to activate. The previous configuration will be completely replaced, potentially leading to loss of management connectivity.
:izi-mced Contigurs Please note: The activated configuration file will not be saved to startup-config automatically.
» Security Configure File Name
» Diagnostics ' startup-config
wMaintenance i
« Restart Device | Activate Configuration [

= Factory Defaults
= Firmware Upgrade
= Firmware Select
wConfiguration

= Download

= Upload

= Activate

= Delete

9.5.4Delete Configuration File

After click ""Maintenance" > "Delete", followed screen will appear. Then user can delete Configuration File.
» Information & Status
» Network Admin

» Port Configure Select configuration file to delete.
»PoE

p Advanced Configure m
» Security Configure - startup-config

» QoS Configure
p Diagnostics

Delete Configuration File

}V Delete Configuration File ]

wMaintenance

= Restart Device
= Factory Defaulis
= Firmware Upgrade
= Firmware Select
w Configuration
= Download
= Upload
= Aclivate
= Delete




Safety Warnings

For your safety, be sure to read and follow all warning notices and instructions.
* Do not open the device. Opening or removing the device cover can expose you to dangerous

high voltage points or other risks. Only qualified service personnel can service the device.

Please contact your vendor for further information.

* Do not use your device during a thunderstorm. There may be a risk of electric shock brought

about by lightning.
* Do not expose your device to dust or corrosive liquids.
* Do not use this product near water sources.
= Make sure to connect the cables to the correct ports.

= Do not obstruct the ventilation slots on the device.



CE & GPL

ALLNET GmbH Computersysteme declares that the device ALL-SGI8104PM is in compliance with the
essential requirements and other relevant provisions of Directive 2014/30/EU. The Declaration of
conformity can be found under this link: http:/ce.allnet.de/

ALLNET GmbH Computersysteme
Maistrasse 2
82110 Germering

Tel.: +49 (0)89 894 222 - 22
Fax: +49 (0)89 894 222 - 33
Email: info@allnet.de

GPL Declaration for ALLNET products

DISCLAIMER_OF WARRANTY
This Program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free
Software Foundation; version 2 of the License.
This Program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
You should have received a copy of the GNU General Public License along with this Program; if not, write to the Free Software Foundation, Inc.,
59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
The full text of the GNU General Public License version 2 is included with the software distribution in the file LICENSE.GPLv2

NO WARRANTY

BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY
APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM
"AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS
WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION. IN NO
EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY
MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL,
INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO
LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO
OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Written Offer for Source Code
For binaries that you receive from ALLNET GmbH Computersysteme on physical media or within the download of the offered firmware that are
licensed under any version of the GNU General Public License (GPL) or the GNU LGPL, you can receive a complete machine-readable copy of the
source code by sending a written request to:

ALLNET GmbH Computersysteme
Maistrasse 2
82110 Germering

Your request should include: (i) the name of the covered binary, (ii) the version number of the ALLNET product containing the covered binary, (iii)
your name, (iv) your company name (if applicable) and (v) your return mailing and email address (if available). We may charge you a nominal fee
to cover the cost of the media and distribution. Your request must be sent within three (3) years of the date you received the GPL or LGPL
covered code. For your convenience, some or all of the source code may also be found at:

http://www.allnet.de/gpl.html

LICENSE.GPLv2
GNU GENERAL PUBLIC LICENSE
Version 2, June 1991
Copyright (C) 1989, 1991 Free Software Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA Everyone is permitted to
copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble
The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is
intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public
License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other
Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.
When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have
the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it,



http://ce.allnet.de/
mailto:info@allnet.de
http://www.allnet.de/gpl.html

that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These
restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You
must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy,
distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software.
If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any
problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will
individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be
licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

GNU GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed
under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the
Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a
portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included
without limitation in the term "modification".) Each licensee is addressed as "you".
Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of
running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the
Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you
conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the
notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License
along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a
fee.
2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and
distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:
a) You must cause the modified files to carry prominent notices  stating that you changed the files and the date of any change.
b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any
part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.
¢) If the modified program normally reads commands interactively when run, you must cause it, when started running for such
interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a
notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under
these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does
not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and
can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to
those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is
a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other
licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise
the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a
volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of
Sections 1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of
Sections and 2 above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of
physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed
under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

¢) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is
allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an
offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete

source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to

control compilation and installation of the executable. However, as a special exception, the source code distributed need not include
anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the
operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access

to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to

copy the source along with the object code.

4.  You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt
otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License.
However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such
parties remain in full compliance.



5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or
distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by
modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and
all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the
original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further
restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to
this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues),
conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do
not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent
license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you,
then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to
apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such
claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by
public license practices. Many people have made generous contributions to the wide range of software distributed through that
system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute
software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original
copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those
countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the
limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new
versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any
later version", you have the option of following the terms and conditions either of that version or of any later version published by
the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever
published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the
author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software
Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all
derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY
APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE
PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND
PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL
NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER
PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE
PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU
OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER
PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it
free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey
the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

<one line to give the program's name and a brief idea of what it does.> Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the
Free Software Foundation; either version 2 of the License, or (at your option) any later version.



This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation,
Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA

Also add information on how to contact you by electronic and paper mail. If the program is interactive, make it output a short notice like
this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type “show w'.

This is free software, and you are welcome to redistribute it under certain conditions; type ‘show c¢' for details.

The hypothetical commands ‘show w' and ‘show c' should show the appropriate parts of the General Public License. Of course, the
commands you use may be called something other than ‘show w' and “show c'; they could even be mouse-clicks or menu items--
whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if
necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program

*Gnomovision' (which makes passes at compilers) written by James Hacker.

<signature of Ty Coon>, 1 April 1989

Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. |f your program is a subroutine library,
you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the
GNU Lesser General Public License instead of this License.

LICENSE.LGPLv2.1
GNU LESSER GENERAL PUBLIC LICENSE
Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA Everyone is permitted
to copy and distribute verbatim copies of this license document, but changing it is not allowed. [This is the first released version of
the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2, hence the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public Licenses
are intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of the Free
Software Foundation and other authors who decide to use it. You can use it too, but we suggest you first think carefully about
whether this license or the ordinary General Public License is the better strategy to use in any particular case, based on the
explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make sure that
you have the freedom to distribute copies of free software (and charge for this service if you wish); that you receive source code or
can get it if you want it; that you can change the software and use pieces of it in new free programs; and that you are informed that
you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender these rights.
These restrictions translate to certain responsibilities for you if you distribute copies of the library or if you modify it.



For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we gave you.
You must make sure that they, too, receive or can get the source code. If you link other code with the library, you must provide
complete object files to the recipients, so that they can relink them with the library after making changes to the library and
recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives you legal
permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is modified by
someone else and passed on, the recipients should know that what they have is not the original version, so that the original author's
reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company cannot
effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist that any
patent license obtained for a version of the library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the GNU Lesser General
Public License, applies to certain designated libraries, and is quite different from the ordinary General Public License. We use this
license for certain libraries in order to permit linking those libraries into non-free programs.

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking a
combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the
entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code with
the library.

We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the ordinary General Public
License. It also provides other free software developers Less of an advantage over competing non-free programs. These
disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license provides
advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it becomes a
de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that a free library
does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to free software
only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body of free
software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the whole GNU
operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a program that is linked
with the Library has the freedom and the wherewithal to run that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between a "work
based on the library" and a "work that uses the library". The former contains code derived from the library, whereas the latter must
be combined with the library in order to run.

GNU LESSER GENERAL PUBLIC LICENSE

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
0. This License Agreement applies to any software library or other program which contains a notice placed by the copyright holder or
other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called "this License").
Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently linked with application programs (which
use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under these terms. A "work based on the
Library" means either the Library or any derivative work under copyright law: that is to say, a work containing the Library or a
portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. (Hereinafter,
translation is included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a library, complete source code means
all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control
compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running a
program using the Library is not restricted, and output from such a program is covered only if its contents constitute a work based
on the Library (independent of the use of the Library in a tool for writing it). Whether that is true depends on what the Library
does and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, provided that you

conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the
notices that refer to this License and to the absence of any warranty; and distribute a copy of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a
fee.



2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and
distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.

¢) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.

d) If afacility in the modified Library refers to a function or a table of data to be supplied by an application program that uses the
facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort to ensure that, in
the event an application does not supply such function or table, the facility still operates, and performs whatever part of its
purpose remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-defined independent of the application.
Therefore, Subsection 2d requires that any application-supplied function or table used by this function must be optional: if the
application does not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library, and
can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those
sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work
based on the Library, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to
the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to
exercise the right to control the distribution of derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the Library) on a
volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the Library. To do
this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public License, version 2,
instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License has appeared, then you can
specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all subsequent
copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4.  You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form under the
terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-readable source code, which
must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source
code from the same place satisfies the requirement to distribute the source code, even though third parties are not compelled to
copy the source along with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being compiled or

linked with it, is called a "work that uses the Library". Such a work, in isolation, is not a derivative work of the Library, and therefore
falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a derivative of the Library (because it contains
portions of the Library), rather than a "work that uses the library". The executable is therefore covered by this License. Section 6
states terms for distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the object code for the work may be a
derivative work of the Library even though the source code is not. Whether this is true is especially significant if the work can be
linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline functions (ten
lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a derivative work.
(Executables containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6. Any
executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself.
6. Asan exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to produce a work
containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit modification of
the work for the customer's own use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are covered by this
License. You must supply a copy of this License. If the work during execution displays copyright notices, you must include the
copyright notice for the Library among them, as well as a reference directing the user to the copy of this License. Also, you must do
one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the Library including whatever changes
were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is an executable linked with the
Library, with the complete machine-readable "work that uses the Library", as object code and/or source code, so that the user can
modify the Library and then relink to produce a modified executable containing the modified Library. (It is understood that the
user who changes the contents of definitions files in the Library will not necessarily be able to recompile the application to use the
modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at run time a copy
of the library already present on the user's computer system, rather than copying library functions into the executable, and (2) will
operate properly with a modified version of the library, if the user installs one, as long as the modified version is interface-
compatible with the version that the work was made with.

¢) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in Subsection
6a, above, for a charge no more than the cost of performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the above
specified materials from the same place.



10.

11.

e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and utility programs needed for

reproducing the executable from it. However, as a special exception, the materials to be distributed need not include anything that is

normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system

on which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally accompany

the operating system. Such a contradiction means you cannot use both them and the Library together in an executable that you

distribute.

You may place library facilities that are a work based on the Library side-by-side in a single library together with other library facilities

not covered by this License, and distribute such a combined library, provided that the separate distribution of the work based on the

Library and of the other library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities.
This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining where to
find the accompanying uncombined form of the same work.

You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any attempt

otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your rights under this

License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so

long as such parties remain in full compliance.

You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or

distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by

modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this License to do so, and all

its terms and conditions for copying, distributing or modifying the Library or works based on it.

Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from the

original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not impose any

further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third

parties with this License.

If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues),

conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do

not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this

License and any other pertinent obligations, then as a consequence you may not distribute the Library at all. For example, if a patent

license would not permit royalty-free redistribution of the Library by all those who receive copies directly or indirectly through you,

then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to

apply, and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such

claims; this section has the sole purpose of protecting the integrity of the free software distribution system which is implemented by
public license practices. Many people have made generous contributions to the wide range of software distributed through that
system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute
software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

12.

13.

If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the original
copyright holder who places the Library under this License may add an explicit geographical distribution limitation excluding those
countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the
limitation as if written in the body of this License.

The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to time. Such
new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to it and "any

14.

15.

16.

later version", you have the option of following the terms and conditions either of that version or of any later version published by
the Free Software Foundation. If the Library does not specify a license version number, you may choose any version ever published
by the Free Software Foundation.
If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with these,
write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free
Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free
status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY
BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY
APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE
LIBRARY "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND
PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY
SERVICING, REPAIR OR CORRECTION.
IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER
PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING
ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY
(INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD
PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Libraries



If you develop a new library, and you want it to be of the greatest possible use to the public, we recommend making it free software that
everyone can redistribute and change. You can do so by permitting redistribution under these terms (or, alternatively, under the
terms of the ordinary General Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start of each source file to most effectively

convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is
found.

<one line to give the library's name and a brief idea of what it does.> Copyright (C) <year> <name of author>

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published
by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the library, if
necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library “Frob' (a library for tweaking knobs) written by James Random Hacker.

<signature of Ty Coon>, 1 April 1990 Ty Coon, President of Vice

That's all there is to it!



